summaryrefslogtreecommitdiff
path: root/mikutter
diff options
context:
space:
mode:
Diffstat (limited to 'mikutter')
-rw-r--r--mikutter/doinst.sh4
-rwxr-xr-xmikutter/mikutter.SlackBuild132
-rw-r--r--mikutter/mikutter.desktop8
-rw-r--r--mikutter/mikutter.info10
-rw-r--r--mikutter/slack-desc19
5 files changed, 173 insertions, 0 deletions
diff --git a/mikutter/doinst.sh b/mikutter/doinst.sh
new file mode 100644
index 0000000..4e8ba70
--- /dev/null
+++ b/mikutter/doinst.sh
@@ -0,0 +1,4 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
diff --git a/mikutter/mikutter.SlackBuild b/mikutter/mikutter.SlackBuild
new file mode 100755
index 0000000..63120b6
--- /dev/null
+++ b/mikutter/mikutter.SlackBuild
@@ -0,0 +1,132 @@
+#!/bin/bash
+
+# Slackware build script for mikutter
+
+# Copyright 2022 Biwa <lqt@lqt.moe>
+# All rights reserved.
+#
+# Based on PKGBUILD for mikutter at Arch User Repository(AUR).
+# (https://aur.archlinux.org/packages/mikutter)
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=mikutter
+VERSION=${VERSION:-5.0.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_lqt}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/lqt-build}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+# Extract additional plugins
+if [ -e $CWD/plugin.tar.gz ]; then
+ tar xvf $CWD/plugin.tar.gz -C plugin
+fi
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+mkdir -p $PKG/opt/mikutter
+cp -a \
+ mikutter.rb Gemfile core plugin \
+ $PKG/opt/mikutter
+
+# Get local Gem install path
+GEMDIR=$(ruby -r rbconfig -e '
+printf("vendor/bundle/%s/%s\n",
+ RbConfig::CONFIG["RUBY_INSTALL_NAME"],
+ RbConfig::CONFIG["ruby_version"]
+ )
+')
+
+# Install Gems
+( cd $PKG/opt/mikutter
+ gem install --no-document --no-user-install -i $GEMDIR rake
+ bundle config --local path vendor/bundle
+ bundle config --local without test
+ MIKUTTER_CONFROOT=./path/to/dummy bundle install
+ rm -rf $GEMDIR/{build_info,cache,doc}
+)
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/bin
+cat <<'EOF' > $PKG/usr/bin/mikutter
+#!/bin/sh
+BUNDLE_GEMFILE=/opt/mikutter/Gemfile bundle exec ruby /opt/mikutter/mikutter.rb
+EOF
+chmod 0755 $PKG/usr/bin/mikutter
+
+mkdir -p $PKG/usr/share/applications
+cp $CWD/mikutter.desktop $PKG/usr/share/applications
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/mikutter/mikutter.desktop b/mikutter/mikutter.desktop
new file mode 100644
index 0000000..111e6b9
--- /dev/null
+++ b/mikutter/mikutter.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=mikutter
+Exec=mikutter
+Icon=/opt/mikutter/core/skin/data/icon_alternative.png
+Terminal=false
+Categories=Network;
diff --git a/mikutter/mikutter.info b/mikutter/mikutter.info
new file mode 100644
index 0000000..f633ed4
--- /dev/null
+++ b/mikutter/mikutter.info
@@ -0,0 +1,10 @@
+PRGNAM="mikutter"
+VERSION="5.0.4"
+HOMEPAGE="https://mikutter.hachune.net/"
+DOWNLOAD="https://mikutter.hachune.net/bin/mikutter-5.0.4.tar.gz"
+MD5SUM="484cec2e96bd9b76da6979b7ad2090de"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Biwa"
+EMAIL="lqt@lqt.moe"
diff --git a/mikutter/slack-desc b/mikutter/slack-desc
new file mode 100644
index 0000000..f778288
--- /dev/null
+++ b/mikutter/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+mikutter: mikutter (simply, powerfully, and moefully multi-service client)
+mikutter:
+mikutter: mikutter is a plugin-extensible multi-service client.
+mikutter: It supports Mastodon and various social network services with plugins.
+mikutter:
+mikutter:
+mikutter:
+mikutter:
+mikutter:
+mikutter:
+mikutter: